this post was submitted on 15 Nov 2024
51 points (94.7% liked)

Programming Horror

1634 readers
1 users here now

Welcome to Programming Horror!

This is a place to share strange or terrible code you come across.

For more general memes about programming there's also Programmer Humor.

Looking for mods. If youre interested in moderating the community feel free to dm @Ategon@programming.dev

Rules

Credits

founded 2 years ago
MODERATORS
 
top 11 comments
sorted by: hot top controversial new old
[โ€“] python@programming.dev 18 points 2 months ago (1 children)

smh, could have used the short form ()=>{ instead of function ๐Ÿ˜ค

[โ€“] Deebster@programming.dev 11 points 2 months ago

I've been coding long enough that I still think of that as a fairly new thing in JS.

[โ€“] Rin@lemm.ee 11 points 2 months ago (1 children)
[โ€“] PoolloverNathan@programming.dev 7 points 2 months ago (1 children)

Someone's handed me nested base-64 encoded JSON before and to this day I am moderately annoyed at them.

[โ€“] MinekPo1@lemmygrad.ml 2 points 2 months ago (1 children)

unity kinda does this ! there is a json file wirh a base-64 encoded string (UTF-16 encoding) and is a completely different data structure with embedded json

I just had to add URL-encoded TOML to something due to a certain Rust crate's constraints.

[โ€“] Kissaki@programming.dev 11 points 2 months ago

In German we say "doppelt hรคlt besser". Is there an English saying like that? "Twice is stronger/more stable/holds better."

[โ€“] GBU_28@lemm.ee 10 points 2 months ago (1 children)

I WILL NOT USE ANOTHER LINE. I DON'T NEED IT

[โ€“] SpicyLizards@reddthat.com 5 points 2 months ago (1 children)

The best code has the fewest lines.

[โ€“] HelloHotel@lemmy.world 1 points 3 weeks ago* (last edited 3 weeks ago)

This is just as easy to write, just as sloppy but hopefully way easier to read.

Game.onload = (data)=>{
let a = data;
a = JSON.decode(a)["saveGame"][0];
a = JSON.decode(a)["SaveGame"];
return a;
}

Why settle on cammel case ("saveGame") or upper cammel case ("SaveGame") when you can have one of each?