337
submitted 11 months ago by 257m@lemmy.ml to c/programming@programming.dev
you are viewing a single comment's thread
view the rest of the comments
[-] OADINC@feddit.nl 54 points 11 months ago* (last edited 11 months ago)

This is the only way;

if (condition) {
    code
}

Not

if (condition)
{
    code
}

Also because of my dyslexia I prefer variable & function names like this; 'File_Acces' I find it easier to read than 'fileAcces'

[-] TopRamenBinLaden@sh.itjust.works 5 points 11 months ago

I think it would be a much hotter take if you had the opposite opinion. I've only met a few of those.

[-] Evilsandwichman@hexbear.net 2 points 11 months ago

I'm not a programmer (I tried learning programming and unity but got lazy so....) but when I learned about if-then statements, the second one seemed like the way it's supposed to be; I mean it looks so clean and simple. Do actual programmers prefer the first method?

[-] firelizzard@programming.dev 4 points 11 months ago

I prefer the first method because it reduces the number of empty lines I have to scroll past and visually filter out

[-] coloredgrayscale@programming.dev 2 points 11 months ago

The 2nd is the style guide used in C#, and therefore what you've encountered in unity.

[-] greywolf0x1@lemmy.ml 4 points 11 months ago* (last edited 11 months ago)

I've only seen the second type in C#, to be fair it makes code neater but i'm glad I left it for Java.

[-] icesentry@lemmy.ca 2 points 11 months ago

How does it make code neater? All it does is add a ton of empty vertical space. It makes files arbitrarily longer at essentially no benefit.

[-] AI_toothbrush@lemmy.zip 3 points 11 months ago

It depends for me. If the condition is some goofy ahh multiline syntax hell i like to use the second option.

[-] mindbleach@sh.itjust.works 2 points 11 months ago

Even then - ) { on a newline.

[-] alcoholicorn@hexbear.net 2 points 11 months ago* (last edited 11 months ago)

I use all 3.

If it's very short and there's 2 or more in a row, I'll put it all in one line.

If there's a bunch of nested if statements, I'll use the second.

If neither of those conditons, I'll use the first.

this post was submitted on 01 Sep 2023
337 points (96.2% liked)

Programming

16687 readers
267 users here now

Welcome to the main community in programming.dev! Feel free to post anything relating to programming here!

Cross posting is strongly encouraged in the instance. If you feel your post or another person's post makes sense in another community cross post into it.

Hope you enjoy the instance!

Rules

Rules

  • Follow the programming.dev instance rules
  • Keep content related to programming in some way
  • If you're posting long videos try to add in some form of tldr for those who don't want to watch videos

Wormhole

Follow the wormhole through a path of communities !webdev@programming.dev



founded 1 year ago
MODERATORS